Verification email not received when resetting Change Vision Members password
Resolving password reset issues for accounts inactive since the March 2025 portal renewal.
Problem
When attempting to reset a password for the Change Vision Members portal, the verification email is never delivered to the inbox, preventing login.
Cause
On March 8, 2025, the Change Vision Portal system was renewed. Password reset functionality does not work for legacy accounts that have not been accessed or migrated since this date.
Solution
To regain access to your information, you must re-register your account. This process will automatically link your existing licenses to the new system.
Step-by-Step Instructions
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Please follow this instruction to create an account with the same email address you used previously.
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Complete the registration and verify your email.
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Log in to the portal.
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Go to the [My Licenses] menu to view your registered license information.